[OPENGL] Gemix Public Testings

Discusión en general sobre Gemix.

Re: [OPENGL] Gemix Public Testings

Postby shao » Sun Jan 27, 2013 6:57 pm

He estado mirando ese post pero el que lo inicio habla de un portatil, no? los problemas que se comentan ahi no coinciden mucho con los que estoy teniendo aunque alguien ha dicho que pruebe con la salida DVI, quiza la VGA esta capada, me parece que si fuese asi, seria una estupidez por parte de ATI, para que capar la salida VGA? bueno, quiero probarlo.

Tambien he encontrado un programa que emula openGL mediante directX
Image

Pero nos ha jodido, para eso me compro yo la tarjeta, para acabar usando este programa, en fin lo he usado pero no me ha funcionado, no consigo hacer que arranque el test, por un fallo o por otro.


He actualizado los drivers, cuando lo he hecho he visto la version de los drivers instalados (para cerciorarme) y efectivamente son los ultimos, aunque son firmados por microsoft no por ATI, no se si eso tendra algo que ver.
La velocidad de frames por segundo con los ultimos drivers es la misma, 178.

He descargado un programa para testear openGL graficamente, resultado desastroso, aparecia una cara en 3d sin texturas y muy indefinida, luego he puesto el mismo programa en mi pc A y se veia perfectamente, asi que parece ser que los drivers openGL en la hd 4650 o estan defectuosos, o no los coge bien o vete a saber que.

Mi placa es una ASrock y en teoria la grafica no deberia dar problemas:
http://www.asrock.com/mb/SiS/K7S41GX/index.es.asp

Ahora estoy probando a instalar algunas cosas que encuentro, como un catalyst que a lo mejor podria funcionar a ver si por algun milagro consigo hacerla funcionar como debe, pero mi veredicto ahora mismo es que esta tarjeta o es defectuosa o existe algun problema con sus drivers o yo que se..

Tambien descargue un programa para hacer un benchmark de la grafica que se llama 3dmark, lo ejecute y funciono todo correctamente aunque claro, lo hacia bajo directX supongo.

Esta es mi tarjtea:
http://www.appinformatica.com/tarjetas- ... mi-agp.php
Ahi pone que soporta openGL 2.1, pero en las especificaciones de ati pone 3.2.
User avatar
shao
 
Posts: 6034
Joined: Wed Jun 17, 2009 4:51 pm

Re: [OPENGL] Gemix Public Testings

Postby CicTec » Sun Jan 27, 2013 7:05 pm

Ya dije en otro thread de offtopic que lo mejor son las graficas NVIDIA, las ATI son buenos los ultimos modelos, los viejos modelos dan muchos problemas.

Lo que puedes hacer es intentar portar nuevamente la tarjeta donde la has comprado, dile que te da muchos problemas y que no puedes hacer casi nada y si te la cambian por una NVIDIA AGP, si el modelo es superior u hay que pagar diferencia, te recomiendo hacerlo y asi eliminas los problemas.
User avatar
CicTec
 
Posts: 16553
Joined: Thu Jul 31, 2008 10:18 pm

Re: [OPENGL] Gemix Public Testings

Postby shao » Sun Jan 27, 2013 7:18 pm

La tarjeta se la compre a un chavalin de mi pueblo que casualmente puso el anuncio en segundamano.es, voy a intentarlo durante un tiempo, si no lo consigo le dire que no me sirve y vere si puedo encontrar otra.
User avatar
shao
 
Posts: 6034
Joined: Wed Jun 17, 2009 4:51 pm

Re: [OPENGL] Gemix Public Testings

Postby CicTec » Sun Jan 27, 2013 7:45 pm

Ok, pero si sigue dando problemas, ante de darsela asegurate de poder obtener otra, sino mejor que te quedas con esta y almenos te servira para testings.
User avatar
CicTec
 
Posts: 16553
Joined: Thu Jul 31, 2008 10:18 pm

Re: [OPENGL] Gemix Public Testings

Postby shao » Sun Jan 27, 2013 9:47 pm

Sí pero de que serviría testear de este modo? Sí la tarjeta no rinde como debe no sería un testeo muy fiable.

Esos 100 procesos que hay en el test están simplemente haciendo frame y nada más?.
User avatar
shao
 
Posts: 6034
Joined: Wed Jun 17, 2009 4:51 pm

Re: [OPENGL] Gemix Public Testings

Postby CicTec » Sun Jan 27, 2013 10:53 pm

Decia en general, no solo en el caso de este test especifico.
User avatar
CicTec
 
Posts: 16553
Joined: Thu Jul 31, 2008 10:18 pm

Re: [OPENGL] Gemix Public Testings

Postby shao » Mon Jan 28, 2013 10:36 am

Sí, yo también quise decir en general, bueno seguiré probando algunas ideas pero no tengo muchas esperanzas.

Ayer pude ver que al correr el ejemplo la CPU va al 100x100, quiero decir que consumía todos sus recursos y me llevó a pensar que de algún modo es la CPU la que esta haciendo todo el trabajo, no la tarjeta de video.
User avatar
shao
 
Posts: 6034
Joined: Wed Jun 17, 2009 4:51 pm

Re: [OPENGL] Gemix Public Testings

Postby Dluk » Mon Jan 28, 2013 2:07 pm

erkosone wrote:Bueno.. pues si decís que es de gama alta.. no se.. no es por llevar la contraria pero esa targeta trae 2 buses a 64 cochinos bits.. eso es gama alta? para un sistema AGP seguramente si, pero una targeta actual de 40 euros funciona 256Bits de bus.. por no hablar de la velocidad de reloj y la velocidad de la memoria que son bastante bajas, pero está claro que a un sistema AGP poco mas se le puede pedir.


No es gama alta, es media tirando a alta :P

Y la versión PCI-E tiene un bus de 128 Bits, es probable que la versión AGP halla sido reducida, supongo que porque los puertos AGP tienen una transferencia máxima de 64 Bits (si mal no recuerdo), aunque no estoy muy seguro de esto. Mi contacto con la técnología AGP fué muy reducido la verdad.

shao wrote:Mi placa es una ASrock y en teoria la grafica no deberia dar problemas:
http://www.asrock.com/mb/SiS/K7S41GX/index.es.asp


Acá tenés un pequeño problema y es que ese mother es horrendo. Desde que estoy en la reparación de PC, he cambiado una enorme cantidad de estos porque tienen muerte súbita o hacen cosas raras... Asrock es la segunda línea de Asus, pero por algún motivo del destino, sus mothers son horribles. Eso sí, acá al menos salen como 4 veces menos que algo de marca.

Si bien no tiene problemas con tu placa, lo que si es seguro es que no la aprovecha para nada. Sospecho que tu placa está operando muy lejos del 100% de su potencia.

shao wrote:Esta es mi tarjtea:
http://www.appinformatica.com/tarjetas- ... mi-agp.php
Ahi pone que soporta openGL 2.1, pero en las especificaciones de ati pone 3.2.


Es que en las especificaciones que están en la página oficial de ATI, ponen las de la versión PCI-E, no las de la AGP, que ya de por sí es distinta, porque por lo que ví, hasta tiene distinto tipo de memoria. La 4650, de hecho, salió en la época que el PCI-E ya estaba bien instalado, por lo que no me extrañaría que la versión AGP que sacaron fuera reducida.

La 4650 que pude testear yo (siempre en PCI-E, por supuesto) tiene la potencia suficiente como para correr el Crysis.


Insisto que para mi el problema no es la VGA, sinó el conjunto de componentes restantes (mother, micro, memoria). Si bien por OpenGL utiliza la VGA para renderizar, supongo que el micro sigue estando presente y sigue siendo un factor importante, lo mismo que la RAM.
Image
"El destino es como un juego... ¿No? Y ahora, esperas mi último movimiento"

Kain - Legacy of Kain: Soul Reaver
User avatar
Dluk
 
Posts: 2422
Joined: Sun Jan 04, 2009 3:51 pm
Location: En el campo de batalla

Re: [OPENGL] Gemix Public Testings

Postby Dluk » Mon Jan 28, 2013 2:17 pm

Acabo de encontrar el problema. No se trata de la placa en sí, sinó de lo nueva que es. Aparentemente, tanto Nvidia como ATI fabricaron sus placas AGP de la era PCI-E utilizando un controlador integrado en la placa, una especie de "convertidor PCI-E a AGP". El resultado es un rendimiento horroroso y la pérdida de OpenGL en varios modelos. Lamentablemente, tu mejor solución es buscar una VGA que sea de la época en la que el puerto AGP reinaba todavía el mercado y, como te dijo CicTec, que sea Nvidia, ya que las ATI de esos tiempos eran bastante malas. Pero para avisar, si conseguís una Nvidia AGP moderna podés tener el mismo problema, así que investigá bien por las dudas.

Además, antes de cambiar la VGA, probá actualizar los drivers AGP de tu motherboard (http://www.asrock.com/mb/SiS/K7S41GX/index.es.asp?cat=Download&os=XP) que, por lo que leí, en ocasiones solucionan el problema.
Image
"El destino es como un juego... ¿No? Y ahora, esperas mi último movimiento"

Kain - Legacy of Kain: Soul Reaver
User avatar
Dluk
 
Posts: 2422
Joined: Sun Jan 04, 2009 3:51 pm
Location: En el campo de batalla

Re: [OPENGL] Gemix Public Testings

Postby shao » Mon Jan 28, 2013 2:39 pm

Los drivers de la placa los tenia actualizados, el problema parece que se extiende entre la placa base y la grafica (o eso me parece despues de leer todo), lo que pasa es que tarjetas agp compatibles con opengl 3.0 no hay practicamente, quiza cuando salio opengl 3.0 ya AGP estaba practicamente en desuso y por eso no hay tarjetas, una de las pocas que hay es una nvidia PCI (no PCIe) que he podido ver en un foro, no recuerdo el modelo pero paso de adquirir una PCI, asi que me quedare con esta para hacer testeos, aunque me da que no seran muy fiables pero bueno, si quiero aprovechar un poco mas ese pc viejo, esta es una opcion.

Es que en las especificaciones que están en la página oficial de ATI, ponen las de la versión PCI-E, no las de la AGP, que ya de por sí es distinta, porque por lo que ví, hasta tiene distinto tipo de memoria. La 4650, de hecho, salió en la época que el PCI-E ya estaba bien instalado, por lo que no me extrañaría que la versión AGP que sacaron fuera reducida.

Si pero bueno, en la caja de la propia tarjeta tambien pone opengl 3.0!.

Tambien mirare si encuentro una placa compatible con mi AMD Athlon que no sea ASrock, aunque lo veo mas dificl pero bueno..

Gracias por la info!.
User avatar
shao
 
Posts: 6034
Joined: Wed Jun 17, 2009 4:51 pm

PreviousNext

Return to General

Who is online

Users browsing this forum: No registered users and 2 guests